Troubleshooting Restore - Mac File System iDataAgent

The following section provides information on some of the troubleshooting scenarios related to restore:

Restore Failures

Some of the files included in the user-defined subclient are not restored.

You may be performing the restore of user-defined subclient along with the restore of default subclient.

When you are recovering data backed up by the default subclient, you cannot recover the data backed up by a user-defined subclient.

Browse from default subclient displays No Backup at Time error

Ensure that you do not include the root directory (/) as the subclient content.

When performing point-in-time restore from the default subclient, include the data/folders under the root directory as the subclient content.

Restore fails when trying to restore to a Unix FAT32 directory

You may be restoring the full contents of a Unix directory that contains more than 32,767 files to a single Unix FAT32 directory.

The number of entries in a single FAT32 directory cannot exceed 32,767.

Error while loading shared libraries

On Linux clients, the below error appears when we run any process or service:

<process name>: error while loading shared libraries: <lib>.so: cannot enable executable stack as shared object requires: Permission denied

For example,

#./ifind_scan -getmnt -all
 ./ifind_scan: error while loading shared libraries: libCvOnTap.so: cannot enable executable stack as shared object requires: Permission denied

As a workaround, do the following steps:

  1. Check if ASL (Atomic Secured Linux) is configured on client.

    #uname –r
     2.6.32.59-17.art.i686.PAE

    .art indicates that ASL is configured on the client.

  2. Check for the presence of the below logs in /var/log/messages file.

    May 24 22:01:08 rhel6 kernel: Aborting core
     May 24 22:01:08 rhel6 kernel: PAX: execution attempt in: <anonymous mapping>, bfc46000-bfc5b000 bffeb000
     May 24 22:01:08 rhel6 kernel: PAX: terminating task: /usr/libexec/paxtest/mprotstack(mprotstack):13201, uid/euid: 0/0, PC: bfc5acf4, SP: bfc5acdc
     May 24 22:01:08 rhel6 kernel: PAX: bytes at PC: c3 1a a3 ae 2b ac 9f ae f4 0f 9f ae 00 00 00 00 f4 0f 9f ae
  3. Run the following command.

    chpax –ps ../iDataAgent/process/service

    E.g.:

    #chpax –ps /opt/commvault/iDataAgent/ifind_scan

ACLs are not restored

Sometimes, when you restore data to a NFS-mounted file system, ACLs and other extended attributes may not be restored.

Restore fails when trying to restore a running executable file.

Ensure that you are not including any running executable files in the restore operation.

Restore operation fails when special characters are included in the data

Restore operations on files containing [], /or the \ characters fail when restored without browsing. In order to restore these files using a browse operation, the directory that contains these files, or a higher level directory, must be selected in the browse window as content to restore.

For example, if there is a file with name file[]name in the /opt directory, then you must select the /opt directory or any directory that contains /opt for restore. If you select only the file, the restore will fail.

Browse and Restore Failure

  • When you browse the latest data on the default subclient after a full backup, the browse window will incorrectly display the top-level directories of any user-defined subclients that have not been backed up. Attempts to restore data from user-defined subclients that have not been backed up will fail.

  • If you do a framed browse (i.e., select both a begin and end date/time for the browse) and select the entire resulting data tree for restore by selecting the top-most (or root) node, an erroneous error message is displayed stating that the restore operation failed. Restores under these circumstances are successful regardless of the error message. To avoid this error message, select the data to be restored from the next-to-highest level in the tree.

Mac operating system restore failed due to kernel panic

During disaster recovery, when rebuilding the operating system, the computer does not restart correctly due to kernel panic. In such cases, refer Apple documentation to recover the system from kernel panic and resume the disaster recovery operation.

CC0008: Users have access to files and folders belonging to others users

Symptom

Users are able to browse, find, and restore files and folders associated with other users from all user interfaces, for example, the CommCell Console and Web Console.

Cause
  • ACLs (Access Control Lists) are not included in the backup

  • The user has the Browse permission instead of only the End User Access permission

Resolution
  1. Configure the End User Access permission on the client computer.

    Assigning the End User Access permission helps to maintain multiple user profiles on the same laptop (or desktop) and ensures that each user has the ability to browse and restore only the data to which he or she has access. For instructions, see Configuring End-User Operations on Client Computers.

  2. If the Browse permission is assigned to these users, remove it.

  3. Make sure the Catalog ACL (end user access control list) option is enabled in the subclients before performing a backup as described in:

  4. Subclient level - Restricting User Access with Access Control Lists (ACLs)

  5. Subclient Policy level - Enabling End User Access Control During Backups

    Note: This option can be enabled only for users who log in with their Active Directory credentials.

Once this option is enabled, ACLs are included in the backup, which allows users to access only files and folders for which they have permissions.

Tip

After enabling this option, run a Full backup. This ensures that ACLs are available in the backup data.
If you run a Differential or Incremental backup after enabling this option, only the newer data will include ACLs.

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