Troubleshooting for DB2 IntelliSnap

Completed with one or more errors

Backup jobs from the DB2 Agent are displayed as "Completed w/ one or more errors" in the Job History window in the following cases:

  • The job is killed after creating some valid data archive files. For example, after running a database backup, the job is killed during the log files phase.

  • An online, offline, or command line backup job completes the data phase but fails during log phase.

  • A log file-only backup job fails or is killed after you backup some log files.

Viewing restore operation log files

You can troubleshoot restore operations by checking the CLDb2Agent restore log file which is located in software installation path\Log Files. Also, you can view detailed information about the restore by issuing the db2ckrst DB2 command and then viewing the generated output. The output for this command lists all the backup images that are included in the restore operation. The command syntax is as follows:

db2ckrst [-d database name] [-t timestamp string]

where:

database name is the name of the database and timestamp string is a numerical value that represents the backup image that is included in the restore operation.

Tip: Timestamps are displayed in the Restore Options dialog box in the CommCell Console.

For example:

db2ckrst -d db_one -t 20030224125749

might generate the following output:

Suggested restore order of images using timestamp 20030224125749

for database db_one

============================================================
 restore db db_one incremental taken at 20030224125749
 restore db db_one incremental taken at 20030224124314
 restore db db_one incremental taken at 20030224125211
 restore db db_one incremental taken at 20030224125749
 =============================================================

Note

The timestamp for the database image that is included in the command appears in the first line and in the last line. The two appearances of the timestamp indicate that this (delta, or incremental) backup image was the most recent backup image in the backup cycle, and therefore was restored first and then last among all the backup images in the cycle.

Database is in s BACKUP_PENDING state

If you modified the LOGARCHMETH1 parameter without then performing an offline full backup after, then the database is left in the BACKUP_PENDING state.

Perform an offline backup. For more information, see Performing a Full DB2 IntelliSnap Backup.

DB20023: A DB2 Backup or Restore Fails when the Device is in CIO Mode

Issue

A DB2 backup or restore fails when the device is in CIO mode.

Resolution

  1. Stop the DB2 instances.

  2. Unmount, and then remount the device by using the -o cio option.

    Example

    mount -v jfs2 -o cio /dev/Q03-db2data1 /db2/Q03/sapdata1

SQL1042c DB2 IntelliSnap Windows Restore Goes Pending

Issue

If either of the following conditions is true between the time that you perform two offline IntelliSnap backup operations, then the restore operation goes into a pending state with a SQL1042c error.:

  • There is no transaction log backup

  • There are no transaction log files

The db2diag.log file contains the following line:

Cannot have 2 entries in GTA with same LFS/LSN values

Cause

This is a DB2 error that happens when there are no transaction logs between multiple IntelliSnap backup operations. For more information, go to the IBM support site, IT18839: FATAL ERROR WHEN TAKING MULTIPLE SNAPSHOT BACKUPS WITH NO TRANSACTION(S) IN BETWEEN.

Resolution

After you complete the first backup operation, make sure that you have a transaction log file, or perform a log backup operation.

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